pipingdesignonline.com

Topic Options
#74378 - 01/29/20 09:36 AM Running Structure 2019 in Plant 2019
DCoody Offline
Member

Registered: 03/03/16
Posts: 31
Loc: Texas, United States
This may have been discussed before but the only post I could find relates to how many licenses are being pulled when running these together.

I cannot get Structure to load into Plant on startup. We are running Plant 2019 and Structure 2019. I have set up all the support file paths and well as updated the Acad.rx as described in the user manual. If I run appload I can see that cadworxstructure.arx is loading on startup but there is no ribbon and the structure commands will not work. Sometimes if I unload cadworxstructure.arx then reload it then it will work and the ribbon loads, but other times when I try this it crashes my autocad session so it is not the ideal workaround.

I came across a discussion somewhere that said that Cloudworx could cause some issues with this so I uninstalled my Cloudworx and tried it and got the same result.
_________________________
Dustin Coody

Top
#74381 - 01/29/20 10:35 PM Re: Running Structure 2019 in Plant 2019 [Re: DCoody]
Vanman Offline
Member

Registered: 02/03/06
Posts: 2668
Loc: JHB South Africa
From the Setup Profile.exe, both products need to be configured to run on the same AutoCAD or BricsCAD platform.

I once had an issue many years ago with Equipment. It turned out plant was configured to run on Autocad 2017 and equipment for some reason was configured for Autocad 2016.

This caused all sorts of mayhem when wanting to run them in a single session.
_________________________
Cadworx User

Top
#74385 - 01/30/20 10:58 AM Re: Running Structure 2019 in Plant 2019 [Re: DCoody]
Matt.Worland Offline
Member

Registered: 07/18/07
Posts: 543
Loc: Denver, CO
Also try and reorder the files in the Acad.rx I believe the user manual has them in the incorrect order. I run SPLM so I cant have both loaded at the same time and I dont recall the correct order.
_________________________
matt worland
ECE Design

Top
#74408 - 02/04/20 10:59 AM Re: Running Structure 2019 in Plant 2019 [Re: DCoody]
DCoody Offline
Member

Registered: 03/03/16
Posts: 31
Loc: Texas, United States
Thanks for the replies. Unfortunately I still can't get it to work. Everything is running on AutoCAD 2019 and I tried rearranging the order of arx files and still nothing. Seems to just be a bug I guess. It is unfortunate as now my pipers will not use the structure portion to draw their MPS's and things like that because they have to open a separate program and it slows them down.
_________________________
Dustin Coody

Top
#74414 - 02/04/20 11:06 PM Re: Running Structure 2019 in Plant 2019 [Re: DCoody]
Vanman Offline
Member

Registered: 02/03/06
Posts: 2668
Loc: JHB South Africa
Are you running the latest builds for all the products ?
_________________________
Cadworx User

Top
#74418 - 02/06/20 06:41 AM Re: Running Structure 2019 in Plant 2019 [Re: DCoody]
DCoody Offline
Member

Registered: 03/03/16
Posts: 31
Loc: Texas, United States
We recently switched from 2016 to 2019 for AutoCAD as well as CADWorx. We decided to go with the 2019 instead of the 2020 so that all of the bugs would be worked out with the service packs and hot fixes. The CADWorx is up to date with SP2 HF2.
_________________________
Dustin Coody

Top
#74420 - 02/06/20 03:59 PM Re: Running Structure 2019 in Plant 2019 [Re: DCoody]
DCoody Offline
Member

Registered: 03/03/16
Posts: 31
Loc: Texas, United States
Matt Worland and I were able to figure this out. Apparently I did not have the latest Service Packs and Hot Fixes installed. Also I used the following order for my Acad.rx file:

CADWorxPlant.arx
CADWorxStructure.arx
StructureDbx.dbx
VueExporter.arx
CADWorxEquipment.arx
sls.arx

Thanks for the help
_________________________
Dustin Coody

Top
#74425 - 02/09/20 05:56 PM Re: Running Structure 2019 in Plant 2019 [Re: DCoody]
dgorsman Offline
Member

Registered: 02/28/06
Posts: 1621
If you don't use the single-line steel palette, you can remove the SLS.ARX as well. I've also had good results with switching the CADWorx Equipment ARX from the ACAD.RX file to a demand-load registry entry, initiated with the command to load the equipment palette, so it saves a bit of time at startup.
_________________________
If you are going to fly by the seat of your pants, expect friction burns.

Top



Moderator:  AimeeFerguson 
Who's Online
0 registered (), 74 Guests and 1 Spider online.
Key: Admin, Global Mod, Mod
February
Su M Tu W Th F Sa
1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
Forum Stats
11739 Members
14 Forums
16167 Topics
72385 Posts

Max Online: 303 @ 01/28/20 11:58 PM
Top Posters (30 Days)
Chill-N 13
Richard Ay 10
Matt.Worland 7
Michael_Fletcher 7
dgorsman 6