Topic Options
#25932 - 03/20/09 11:12 AM PvElite application error
fedeghi Offline
Member

Registered: 01/02/08
Posts: 61
Loc: Milan, Italy
My PvElite 2009 installation is not working anymore.
The application does not start, a system error occurs each time I try to start it.
CodeCalc is working properly, and so does PvElite 2008.
I have already unistalled and installed again PvElite2009 and HASP manager, but the problem is not solved.

Any idea on how to face the problem? Is there any Coade diagnostic tool that I should run?
Thanks

Top
#25935 - 03/20/09 12:17 PM Re: PvElite application error [Re: fedeghi]
Scott_Mayeux Offline

Member

Registered: 12/23/99
Posts: 347
Loc: Houston,TX,USA
Fedeghi,

You need to send us a screen capture with the error and then we should be able to help you sort this out. Any other helpful information is also appreciated.
_________________________
Scott Mayeux
CADWorx & Analysis Solutions
Intergraph Process, Power, & Marine

Top
#25960 - 03/23/09 01:16 AM Re: PvElite application error [Re: Scott_Mayeux]
fedeghi Offline
Member

Registered: 01/02/08
Posts: 61
Loc: Milan, Italy
I'm contacting our local distributor.

Meanwhile, here is the event log text. To me it (obviously) doesn't make sense.

- System

- Provider

[ Name] Application Error

- EventID 1000

[ Qualifiers] 0

Level 2

Task 100

Keywords 0x80000000000000

- TimeCreated

[ SystemTime] 2009-03-23T07:11:07.000Z

EventRecordID 6847

Channel Application

Computer PRS-FGHIONI.desmetballestra.lan

Security


- EventData

pve.exe
2009.8.10.31
4950f572
ntdll.dll
6.0.6001.18000
4791a7a6
c0000005
000659c3
15cc
01c9ab8685dff9aa


Attachments
635-pvelitecrash.jpg




Edited by fedeghi (03/23/09 01:43 AM)
Edit Reason: screenshot added

Top
#25986 - 03/23/09 05:31 PM Re: PvElite application error [Re: fedeghi]
Mandeep Singh Offline

Member

Registered: 12/15/99
Posts: 600
Loc: Houston, Tx, USA
Is it Vista OS? if so then follow these instructions,

The problem that you are encountering in Vista is not related to the key. Instead the culprit is the PV Elite “system” folder. In previous releases the PV Elite “system” folder was stored underneath PV Elite itself which was typically in the Program Files area. We allow users to add material which are stored in the system folder. This violates the rules of Microsoft, as they do not want programs to write anything in the program files folder. To solve this problem we moved system folder to “%allusersprofile%” location in the 2009 version.

But, we have found that Microsoft changed its mind regarding it and on Vista OS, the “users” accounts do not have read and write permission to this folder. When you start PV Elite it has to write a file in its system folder and if it cannot the error occurs.

You can get to the PV Elite system folder by typing %allusersprofile% in the Windows Explorer and pressing Enter. On my Win XP computer this is,

C:\Documents and Settings\All Users\Application Data\COADE, Inc\pvelite\2009\System

On a Vista computer, this is in the C:/Program Data folder.

On Vista, even the administrators are given user rights due to UAC. This UAC acts like a cop and prompts for permission if anything needs elevated rights. I will suggest following steps,

1. Go to the PV Elite 2009 system folder (as indicated above) and change the security permission for this folder to allow users to have read and write (create) permissions.

2. You could disable UAC.

3. You could set to run PV Elite program as an administrator, so every time it starts it will prompt for permission. You can right click on the pve.exe in the installation folder to set this.

In future version, we will try to set the permission to the PV Elite system folder in the installation itself.
_________________________
Best Regards,
Mandeep Singh
CADWorx & Analysis Solutions
Hexagon PPM

Top
#25996 - 03/24/09 01:54 AM Re: PvElite application error [Re: Mandeep Singh]
fedeghi Offline
Member

Registered: 01/02/08
Posts: 61
Loc: Milan, Italy
Dear Mandeep,

thanks for your reply, unfortunately it seems that your suggestions did not solve the problem.

I have set "read and write" permission on the PvElite folders under Program Data folder, UAC is disabled and I'm also trying to run pve.exe with admin privileges (in fact, my user account is already "administrator"), right-clicking on pve.exe and launching the program as an admin.
I keep getting the same error.

Yesterday I spoke with our local dealer, and I have sent him all the informations that I could gather (diagnotic report from HASP SRM, ESL data using pulse.exe and some other stuff...). I think that he will have to forward everything to you.

Please note that PvElite2009 worked fine until last week, when suddenly it stopped to work.

Top
#26068 - 03/25/09 11:19 AM Re: PvElite application error [Re: fedeghi]
fedeghi Offline
Member

Registered: 01/02/08
Posts: 61
Loc: Milan, Italy
I would like to thank COADE technicians: with their help the problem on my machine has been solved smile

Top
#26205 - 03/30/09 12:56 AM Re: PvElite application error [Re: fedeghi]
fedeghi Offline
Member

Registered: 01/02/08
Posts: 61
Loc: Milan, Italy
Something is once again not working correctly.
Last week the problem was solved by setting the "compatibility option" of pve.exe to windows XP compatibility.
Now PvElite is not running both in "Vista mode" and "XP mode".
I have tried to set "Windows 2000" comptibility and the program starts, but I'm wondering what's going on and, most important, what if the "windows 2000 compatibility" will not work anymore in a couple of days?

I can't stop my work at the moment, so I'm proceeding with this compatibility setting.
Anyway, it seems that the problem is not solved, but only temporarily bypassed

EDITED AT 1 p.m. : at the moment pvelite is beginning to create problems also with windows 2000 compatibility. I closed it before lunchtime, and when I came back it wouldn't start. I have reboot the PC, and now PV is running. It's unpredictable.

2nd EDIT: the file that was last written in the PvElite/system directory, before my lunchtime break, is called pve3dcolors.xml
Could it be the source of the problem? Infact it seems to me that before crashing, PvElite tries to start but it gets stuck when it has to resolve the graphic interface (see the attached pic in my previous posts).
Now that PvElite is running, I have reset to default the colors in 3d graphic environment... let see if the problem pops up again.
By the way, it seems to me that this file is not deleted when you uninstall pvelite. This would explain why in the past week, even if I uninstalled and then reinstalled pvelite, it did not work.

Sorry for the continuous flood of posts, but I'm trying to give you as much information as I can about my problem.

3rd EDIT: another update. Now PvElite won't run anymore, regardless of VISTA / XP / 2000 compatibilities frown
It will only run if I set to run pve.exe in 264 color. This, once again, makes me think that there is a problem with the rendering graphics.


I'll copy and paste everything in an email, and send it to assistance.
Ciao!


Edited by fedeghi (03/30/09 07:52 AM)

Top
#26382 - 04/03/09 07:03 AM Re: PvElite application error [Re: fedeghi]
Chris-AutoSoft Offline
Member

Registered: 12/24/07
Posts: 1
Loc: Taipei,Taiwan
Hellow fedeghi,
May be you can check your PC, whether it is VGA on main board?
If is, i suggest you can add a VGA card on your PC.

Top



Who's Online
0 registered (), 117 Guests and 2 Spiders online.
Key: Admin, Global Mod, Mod
May
Su M Tu W Th F Sa
1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31
Forum Stats
12065 Members
14 Forums
16973 Topics
75151 Posts

Max Online: 303 @ 01/28/20 11:58 PM
Top Posters (30 Days)